venerdì 8 aprile 2011

Come si utilizza CONTASE - Come si utilizza COUNTIF - Come si scrive CONTASE - Come si usa CONTASE


SE VOGLIAMO CONTARE QUANTE VOLTE  UN NUMERO O UNA LETTERA O UNA PAROLA
E' CONTENUTA IN UNA COLONNA O IN UN GRUPPO DI COLONNE O CASELLE.
DOBBIAMO USARE LA FUNZIONE "CONTASE" (in Italiano) O "COUNTIF" (in Inglese ).
IN OGNI CASO A PRESCINDERE DALLA LINGUA IL FUNZIONAMENTO E' LO STESSO, LA
FUNZIONE SI SCRIVE COSI.



IF I want to count how many times a number or a letter or word
E 'in a column or group of columns or cells.
We use " COUNTIF".

Conta il numero di celle in un intervallo che soddisfano i criteri specificati.

Sintassi

CONTA.SE(intervallo;criteri)
Intervallo  indica una o più celle da contare, contenenti numeri o nomi, matrici o riferimenti che contengono numeri. Le celle vuote e i valori di testo verranno ignorati.
Criteri  sono i criteri in forma di numeri, espressioni, riferimenti di cella o testo che determinano quali celle verranno contate. I criteri possono, ad esempio, essere espressi come 32, "32", ">32", "mele" o "B4".

Osservazioni

  • Nei criteri è possibile utilizzare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Questi ultimi rappresentano rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) davanti al carattere.

Esempio 1: formule CONTA.SE comuni

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.
 
1
2
3
4
5
AB
DatiDati
mele32
arance54
pesche75
mele86
FormulaDescrizione (risultato)
=CONTA.SE(A2:A5;"mele")Numero di celle contenenti "mele" nella prima colonna (2)
=CONTA.SE(A2:A5;A4)Numero di celle contenenti "pesche" nella prima colonna (1)
=CONTA.SE(A2:A5;A3)+CONTA.SE(A2:A5;A2)Numero di celle contenenti "arance" nella prima colonna (3)
=CONTA.SE(B2:B5;">55")Numero di celle contenenti un valore maggiore di 55 nella seconda colonna (2)
=CONTA.SE(B2:B5;"<>"&B4)Numero di celle contenenti un valore diverso da 75 nella seconda colonna (3)
=CONTA.SE(B2:B5;">=32")-CONTA.SE(B2:B5;">85")Numero di celle contenenti un valore maggiore o uguale a 32 e minore o uguale a 85 nella seconda colonna (3)

Esempio 2: formule CONTA.SE che utilizzano caratteri jolly e gestiscono l'assenza di valori

L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.
 
1
2
3
4
5
6
7
AB
DatiDati
mele
aranceNO
pescheNo
mele
FormulaDescrizione (risultato)
=CONTA.SE(A2:A7;"*e")Numero di celle che terminano con le lettere "le" nella prima colonna (2)
=CONTA.SE(A2:A7;"????ce")Numero di celle che terminano con le lettere "ce" e con esattamente 6 lettere nella prima colonna (2)
=CONTA.SE(A2:A7;"*")Numero di celle contenenti testo nella prima colonna (4)
=CONTA.SE(A2:A7;"<>"&"*")Numero di celle non contenenti testo nella prima colonna (2)
=CONTA.SE(B2:B7;"No") / RIGHE(B2:B7)Il numero medio di voti No includendo le celle vuote nella seconda colonna, formattato come percentuale senza posizioni decimali (33%)
=CONTA.SE(B2:B7;"Sì") / (RIGHE(B2:B7) -CONTA.SE(B2:B7; "<>"&"*"))Il numero medio di voti Sì escludendo le celle vuote nella seconda colonna, formattato come percentuale senza posizioni decimali (50%)
 Nota     È possibile visualizzare il numero come percentuale. Selezionare la cella e nel gruppo Numero della scheda Foglio fare clic su Stile percentuale .

Nessun commento: