venerdì 8 aprile 2011

Come funziona CERCAVERT - Come funziona VLOOKUP - Come si usa CERCAVERT - Come si scrive CERCAVERT



Come si scrive la funzione Cerca verticale - come si scrive la funzione Vlookup , come si estraggono dati da una tabella.

Per prima cosa dobbiamo stabilire in quale casella vogliamo ottenere il risultato della nostra ricerca ( es. in G6 casella gialla ),  poi dobbiamo procedere alla ricerca della funzione CERCA.VERT e all'inserimento dei parametri .






Di seguito i 4parametri fondamentali da indicare nella funzione CERCA.VERT.



Possiamo quindi dire che la funzione ha cercato il numero scritto nella casella che gli abbiamo indicato ( F6 verde ), nella tabella C6:D15 e ci ha dato il valore corrispondente al numero 3 scritto nella colonna 2, riportandolo nella casella gialla G6.



Se nella casella verde scriviamo un'altro numero es.7 nella casella gialla il risultato sarebbe Mara, e cosi via.


QUI ho fatto un'altro Blog che ti potrebbe interessare

Per altre informazioni clicca QUI


SE TI INTERESSA UN ARGOMENTO SPECIFICO SCRIVILO NELLA CASELLA "CERCA NEL BLOG" ( sopra a destra ) E TROVERAI TUTTI GLI ARTICOLI AD ESSO RELATIVI











Vedi anche

Tabella PIVOT - spiegazioni come funziona
MACRO - come si crea e come funziona una macro
SOMMA.SE - come si crea, come funziona
GRAFICI - come si creano i grafici
FILTRI - creazione, utilizzo, gestione dei filtri in Excel


Di seguito l'istruzione di EXCEL completa , per la funzione CERCA.VERT

CERCA.VERT
Comment ne CERCAVERT - Comment VLOOKUP - Comment utiliser CERCAVERT - Comment épelez-vous CERCAVERT
Cerca un valore nella prima colonna di una matrice tabella e lo restituisce nella stessa riga di un'altra colonna.
La parola VERT in CERCA.VERT indica l'orientamento verticale. Utilizzare la funzione CERCA.VERT invece di CERCA.ORIZZ quando i valori di confronto sono collocati in una colonna a sinistra dei dati che si desidera trovare.

Sintassi

CERCA.VERT(valore;matrice_tabella;indice;intervallo)
Valore  Valore da cercare nella prima colonna della matrice (matrice: Utilizzata per definire singole formule che producono più risultati o che operano su un gruppo di argomenti disposti in righe e colonne. Un intervallo di matrice condivide una formula comune, una costante di matrice è invece un gruppo di costanti utilizzato come argomento.) tabella. Può essere un valore o un riferimento. Se è minore del valore più piccolo nella prima colonna della matrice_tabella, CERCA.VERT restituirà il valore di errore #N/D.
Matrice_tabella  Due o più colonne di dati. Utilizzare un riferimento a un intervallo o a un nome di intervallo. I valori nella prima colonna di matrice_tabella sono i valori cercati da valore e possono essere costituiti da testo, numeri o valori logici. Le lettere maiuscole e minuscole si equivalgono.
    Indice  Numero di colonna nella matrice_tabella dal quale deve essere restituito il valore corrispondente. Un indice con valore 1 restituisce il valore nella prima colonna di matrice_tabella. Un indice con valore 2 restituisce il valore nella seconda colonna di matrice_tabella e così via. Se indice è:
    • Minore di 1, CERCA.VERT restituirà il valore di errore #VALORE!.
    • Maggiore del numero di colonne di matrice_tabella, CERCA.VERT restituirà il valore di errore #RIF!.
    Intervallo  Valore logico che specifica se si desidera trovare una corrispondenza esatta o approssimativa mediante la funzione CERCA.VERT:
    • Se è VERO o è omesso, verrà restituita una corrispondenza esatta o approssimativa. Se non viene trovata alcuna corrispondenza esatta, verrà restituito il successivo valore più grande, inferiore a valore. I valori nella prima colonna di matrice_tabella devono essere collocati in ordine crescente. In caso contrario, CERCA.VERT potrebbe non restituire il valore corretto. Per ulteriori informazioni, vedere Ordinare i dati.
    • Se è FALSO, CERCA.VERT troverà solo una corrispondenza esatta. In questo caso, non sarà necessario ordinare i valori della prima colonna di matrice_tabella. Se in tale colonna sono presenti due o più valori che corrispondono a valore, verrà utilizzato il primo valore trovato. Se non viene trovata alcuna corrispondenza esatta, verrà restituito il valore di errore #N/D.

    Osservazioni

    • Quando si cercano valori di testo nella prima colonna di matrice_tabella, assicurarsi che i dati in tale colonna non contengano spazi iniziali, spazi finali, un uso non coerente delle virgolette semplici ( ' o " ) e inglesi ( ‘ o “) o caratteri non stampabili. In questi casi, CERCA.VERT potrebbe restituire un valore non corretto o imprevisto. Per ulteriori informazioni, vedere le funzioni LIBERA e ANNULLA.SPAZI.
    • Quando si cercano valori numerici o di dati, assicurarsi che i dati nella prima colonna di tabella_matrice non siano memorizzati come valori di testo. In questo caso, CERCA.VERT potrebbe restituire un valore non corretto o imprevisto. Per ulteriori informazioni, vedere Convertire in numeri i numeri memorizzati come testo.
    • Se intervallo è FALSO e valore corrisponde a un testo, è possibile utilizzare i caratteri jolly, ovvero il punto interrogativo (?) e l'asterisco (*). Questi ultimi rappresentano rispettivamente un carattere singolo e una sequenza di caratteri qualsiasi. Se si desidera trovare un punto interrogativo o un asterisco, digitare una tilde (~) davanti al carattere.

      Esempio 1

      L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.
      Creare una cartella di lavoro o un foglio di lavoro vuoto.
      In questo esempio viene effettuata una ricerca nella colonna Densità di un tabella di proprietà atmosferiche per trovare i valori corrispondenti nelle colonne Viscosità e Temperatura. I valori si riferiscono a un'aria di 0 gradi Celsius al livello del mare o di 1 atmosfera.
       
      1
      2
      3
      4
      5
      6
      7
      8
      9
      10
      ABC
      DensitàViscositàTemperatura
      0,4573,55500
      0,5253,25400
      0,6162,93300
      0,6752,75250
      0,7462,57200
      0,8352,38150
      0,9462,17100
      1,091,9550
      1,291,710
      FormulaDescrizione (risultato)
      =CERCA.VERT(1;A2:C10;2)Utilizzando una corrispondenza approssimativa, cerca il valore 1 nella colonna A, trova il valore più grande che è minore o uguale a 1 nella colonna A, ovvero 0,946, e restituisce il valore della colonna B nella stessa riga. (2,17)
      =CERCA.VERT(1;A2:C10;3;VERO)Utilizzando una corrispondenza approssimativa, cerca il valore 1 nella colonna A, trova il valore più grande minore o uguale a 1 nella colonna A, ovvero 0,946, e restituisce il valore della colonna C nella stessa riga. (100)
      =CERCA.VERT(0,7;A2:C10;3;FALSO)Utilizzando una corrispondenza esatta, cerca il valore 0,7 nella colonna A. Poiché non esiste alcuna corrispondenza esatta nella colonna A, verrà restituito un errore. (#N/D)
      =CERCA.VERT(0,1;A2:C10;2;VERO)Utilizzando una corrispondenza approssimativa, cerca il valore 0,1 nella colonna A. Poiché 0,1 è minore del valore più piccolo nella colonna A, verrà restituito un errore. (#N/D)
      =CERCA.VERT(2;A2:C10;2;VERO)Utilizzando una corrispondenza approssimativa, cerca il valore 2 nella colonna A, trova il valore più grande minore o uguale a 2 nella colonna A, ovvero 1,29, e restituisce il valore della colonna B nella stessa riga. (1,71)

      Esempio 2

      L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.
      Creare una cartella di lavoro o un foglio di lavoro vuoto.
      In questo esempio viene effettuata una ricerca nella colonna ID articolo di una tabella di prodotti per l'infanzia e vengono trovati i valori corrispondenti nelle colonne Costo e Margine di profitto per calcolare prezzi e condizioni di prova.
       
      1
      2
      3
      4
      5
      6
      ABCD
      ID articolo Articolo Costo Margine di profitto
      ST-340Passeggino€ 145,67 30%
      BI-567Bavaglino€ 3,56 40%
      DI-328Pannolini € 21,45 35%
      WI-989Salviettine € 5,12 40%
      AS-469Aspiratore€ 2,56 45%
      FormulaDescrizione (risultato)
      = CERCA.VERT ("DI-328"; A2:D6; 3; FALSO) * (1 + CERCA.VERT("DI-328"; A2:D6; 4; FALSO)) Calcola il prezzo al dettaglio dei pannolini aggiungendo la percentuale di margine di profitto al costo. (€ 28,96)
      = (CERCA.VERT("WI-989"; A2:D6; 3; FALSO) * (1 + CERCA.VERT("WI-989"; A2:D6; 4; FALSO))) * (1 - 20%)Calcola il prezzo di vendita delle salviettine sottraendo un determinato sconto dal prezzo al dettaglio. (€ 5,73)
      = SE(CERCA.VERT(A2; A2:D6; 3; FALSO) >= 20, "Il margine di profitto è " & 100 * CERCA.VERT(A2; A2:D6; 4; FALSO) &"%", "Il costo è inferiore a € 20,00")Se il costo di un articolo è maggiore o uguale a € 20,00, verrà visualizzata la stringa "Il margine di profitto è nn%". In caso contrario, verrà visualizzata la stringa "Il costo è inferiore a € 20,00". (Il margine di profitto è pari al 30%)
      = SE(CERCA.VERT(A3; A2:D6; 3; FALSO) >= 20, "Il margine di profitto è: " & 100 * CERCA.VERT(A3; A2:D6; 4; FALSO) &"%", "Il costo è €" & CERCA.VERT(A3; A2:D6; 3; FALSO)) Se il costo di un articolo è maggiore o uguale a € 20,00, verrà visualizzata la stringa "Il margine di profitto è nn%". In caso contrario, verrà visualizzata la stringa "Il costo è € n.nn". (Il costo è pari a € 3,56)

      Esempio 3

      L'esempio può essere più semplice da comprendere se lo si copia in un foglio di lavoro vuoto.
      Creare una cartella di lavoro o un foglio di lavoro vuoto.
      In questo esempio viene effettuata una ricerca nella colonna ID di una tabella di dipendenti e vengono trovati i valori corrispondenti nelle altre colonne per calcolare le età ed eseguire una prova delle condizioni di errore.
       
      1
      2
      3
      4
      5
      6
      7
      ABCDE
      ID CognomeNome TitoloData di nascita
      1GiorgiAdrianaAgente di vendita 08/12/1968
      2GarghentiniDavideVicepresidente Vendite19/02/1952
      3LeonettiFrancescaAgente di vendita30/08/1963
      4ScottiElisabettaAgente di vendita19/09/1958
      5BarbariolAngelaDirettore vendite04/03/1955
      6SasonFedericoAgente di vendita 02/07/1963
      FormulaDescrizione (risultato)
      =INT(FRAZIONE.ANNO(DATA(2004;6;3); CERCA.VERT(5;A2:E7;5; FALSO); 1))Per l'anno fiscale 2004, trova l'età del dipendente con l'ID 5. Utilizza la funzione FRAZIONE.ANNO per sottrarre la data di nascita dalla data finale dell'anno fiscale e visualizza il risultato come valore intero utilizzando la funzione INT. (49)
      =SE(VAL.NON.DISP(CERCA.VERT(5;A2:E7;2;FALSO)) = VERO; "Dipendente non trovato"; CERCA.VERT(5;A2:E7;2;FALSO))Se esiste un dipendente con l'ID 5, ne visualizza il cognome. In caso contrario, visualizza il messaggio "Dipendente non trovato". (Barbariol) La funzione VAL.NON.DISP restituisce un valore VERO quando la funzione CERCA.VERT restituisce il valore di errore #ND.
      =SE(VAL.NON.DISP(CERCA.VERT(15;A3:E8;2;FALSO)) = VERO; "Dipendente non trovato"; CERCA.VERT(15;A3:E8;2;FALSO))Se esiste un dipendente con l'ID 15, ne visualizza il cognome. In caso contrario, visualizza il messaggio "Dipendente non trovato". (Dipendente non trovato) La funzione VAL.NON.DISP restituisce un valore VERO quando la funzione CERCA.VERT restituisce il valore di errore #ND.
      =CERCA.VERT(4;A2:E7;3;FALSO) & " " & CERCA.VERT(4;A2:E7;2;FALSO) & " è un " & CERCA.VERT(4;A2:E7;4;FALSO) & "."Per il dipendente con l'ID 4, concatena i valori delle tre celle in modo da formare una frase completa. (Elisabetta Scotti è un'agente di vendita

      Nessun commento: